Sunday 4 May 2014

Hands-on LAB: Konfigurasi dasar PPP


Task 4: Configure OSPF on all the Routers
Task 5: Configure PPP encapsulation on Serial Interfaces
Task 6: 
Task 7: Break PPP encapsulation and restore it back
Task 8: Configure PPP authentication: CHAP
Task 9: Intentionally break PPP CHAP authentication and restore it back again


R1(config)# interface fa0/1
R1(config-if)# ip address 192.168.10.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# interface serial 0/0/0
R1(config-if)# ip address 10.1.1.1 255.255.255.252
R1(config-if)# no shutdown
R1(config-if)# router ospf 1
R1(config-router)# network 192.168.1.0 0.0.0.255 area 0
R1(config-router)# network 10.1.1.0 0.0.0.3 area 0


R2(config)# interface s0/0/0
R2(config-if)# ip address 10.1.1.2 255.255.255.252
R2(config-if)# no shutdown
R2(config-if)# interface s0/0/1
R2(config-if)# ip address 10.2.2.1 255.255.255.252
R2(config-if)# no shutdown
R2(config-if)# interface lo0
R2(config-if)# ip add 209.165.200.225 255.255.255.224
R2(config-if)# no shutdown
R2(config-if)# router ospf 1
R2(config-router)# network 10.1.1.0 0.0.0.3 area 0
R2(config-router)# network 10.2.2.0 0.0.0.3 area 0
R2(config-router)# network 209.165.200.224 0.0.0.31 area 0

R3(config)# interface s0/0/1
R3(config-if)# ip address 10.2.2.2 255.255.255.252
R3(config-if)# no shutdown
R3(config-if)# interface fa0/1
R3(config-if)# ip address 192.168.30.1 255.255.255.0
R3(config-if)# no shutdown
R3(config-if)# router ospf 1
R3(config-router)# network 10.2.2.0 0.0.0.3 area 0
R3(config-router)# network 192.168.30.0 0.0.0.255 area 0

R1# show ip route
R1# ping 192.168.30.1

R2# show ip route
R2# ping 192.168.30.1
R2# ping 192.168.10.1

R3# show ip route
R3# ping 209.165.200.225
R3# ping 192.168.10.1

R1# show interface serial 0/0/0
R2# show interface serial 0/0/0
R2# show interface serial 0/0/1
R3# show interface serial 0/0/1

R1# debug ppp negotiation
R1# debug ppp packet

R2# debug ppp negotiation
R2# debug ppp packet

R1(config)# interface serial 0/0/0
R1(config-if)# encapsulation ppp
R2(config)# interface serial 0/0/0
R2(config-if)# encapsulation ppp

Matiin debugging R1 dan R2

R1# undebug all
R2# undebug all

Rubah enkapsulasi HDLC ke PPP di kedua ujung link serial R2-R3

R2(config)# interface serial 0/0/1
R2(config-if)# encapsulation ppp
R3(config-if)# interface serial 0/0/1
R3(config-if)# encapsulation ppp

Cek apakah enkapsulasi di serial interface sekarang sudah berubah menjadi PPP?
R1# show interface serial 0/0/0
R2# show interface serial 0/0/0
R2# show interface serial 0/0/1
R3# show interface serial 0/0/1

Putusin dan balikin lagi enkapsulasi PPP
R2(config)# interface serial 0/0/0
R2(config-if)# encapsulation hdlc
R2(config-if)# interface serial 0/0/1
R2(config-if)# encapsulation hdlc

Balikin lagi
R2(config)# interface s0/0/0
R2(config-if)# encapsulation ppp
R2(config-if)# interface s0/0/1
R2(config-if)# encapsulation ppp

Konfigurasi jenis autentikasi PPP menggunakan PAP pada link antara R1 dan R2
R1(config)# username R1 password cisco
R1(config-if)# int s0/0/0
R1(config-if)# ppp authentication pap
R1(config-if)# ppp pap sent-username R2 password cisco

R2(config)# username R2 password cisco
R2(config)# interface serial 0/0/0
R2(config-if)# ppp authentication pap
R2(config-if)# ppp pap sent-username R1 password cisco

Konfigurasi jenis autentikasi yang dipakai PPP menggunakan CHAP untuk link antara R2 dan R3
R2(config)# username R3 password cisco
R2(config)# int s0/0/1
R2(config-if)# ppp authentication chap

R3(config)# username R2 password cisco
R3(config)# int s0/0/1
R3(config-if)# ppp authentication chap

Review the debug output
R2# debug ppp authentication
R2# conf t
R2(config)# int s0/0/1
R2(config-if)# shutdown
R2(config-if)# no shutdown

R3# debug ppp authentication

Putusin PPP CHAP authentication
R2# conf t
R2(config)# int s0/0/1
R2(config-if)# ppp authentication pap
R2(config-if)# ^Z
R2# copy run start
R2# reload

Balikin PPP CHAP authentication
R2# configure terminal
R2(config)# interface s0/0/1
R2(config-if)# ppp authentication chap

Putusin PPP CHAP authentication dengan merubah password pada R3
R3# configure terminal
R3(config)# username R2 password ciisco
R3(config)# ^Z
R3# copy run start
R3# reload

Balikin PPP CHAP authentication dengan mengembalikan password pada R3 kesemula
R3# configure terminal
R3(config)# username R2 password cisco

No comments:

Post a Comment